注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

学无止境

一点积累,与大家分享

 
 
 

日志

 
 

业余框架整合-SSHD-(1)-整体概述(2011-06-02更新)  

2011-09-13 14:42:58|  分类: jsp技术 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
2011-06-01更新说明:环境配置都不变,jar包更新,修复了登录验证错误和用户权限验证的功能缓存,还有其它一些不记得的小问题,业余框架整合-SSHD-(1)-整体概述(2011-06-02更新) - 每天积累一点 - 学无止境 这个版本是我在私活中的一个物流版本上删减客户功能直接导出来的,做这个项目发现不少问题,还有一些实用的功能待有时间再加

再个我实在仍受不了myeclipse那速度,改eclipse了,项目是直接eclipse导出来的,还一个myeclipse版

备注:项目开始时间是2010年9月份,当时有段时间上班很闲,没多想就开始做了,直到现在中间只是有时间就做做,组件也是一个慢慢加上去的,整 合中也遇到很多问题,靠着网络算是一个人都走下来了,这些组件个人认为项目都是很可能遇到的才加进来,有的也只是写了个hello world的实现

发表出来的主要目的:为同行的新手提供一个框架整合的例子,有时间我会把细节在今后都更新出来(中间整合的也可能有问题,如发现请指出,个人能力有限,望包涵)

一、基础介绍

1.目的:主要是练手,其次是做个通用的公共平台,涉及到权限和工作流
 
2.用到的主要框架和组件:
  struts2.2.1(mvc框架)
  spring2.5.6(平台枢纽)
  hibernate3.5.5(数据库封装)
  dwr2(便捷ajax框架)
  jbpm4.4(工作流引擎)
  compass2.2(站内搜索)
  cxf2.2(web services框架)
  quartz1.8(定时任务)
  kindEditor(js文本编辑器,类似于FCKEdit)
  jna(jni封装)
  BoneCP0.7(传说最高效的数据源,必须达到jdk6版本)
  osCache2.4(缓存平台,一是作为hibernate缓存插件,二是缓存所有数据字典和所有操作的URL)
  freemark2.3(生成html静态网页)

3.运行说明:
  3.1.web server:
   3.1.1.tomcat5.5: 把jbpm_juel_jar.rar中3个jar包放入到项目中即可
   3.1.2.tomcat6: 用tomcat6,把jbpm_juel_jar.rar中3个jar包放入tomcat6的lib目录,删掉tomcat6\lib中的el-api.jar

  3.2.数据库用mysql5,新建一个数据库sshd,编码是UTF-8,然后倒入sshd_sql_mysql.rar脚本,我用的是Navicat Lite导出的,导入最好也用同样的工具,不然很容易出现问题

  3.3.源码包是SSHD-日期.rar,其中所有的文件编码都是UTF-8,以lib开头的是项目用到的所有jar包(由于单个文件大小的限制所以分开 打包了),解压SSHD.rar然后用myeclipse直接导入项目,把解压的所有jar都放到WEB-INF\lib目录下

  3.4.数据库连接信息都在src下的init.properties中,根据自己情况修改用户名密码

  3.5.如果你是用的linux,请把mysql中区分表名大小写去掉

  3.6.关于JDK版本说明:
     3.6.1.JDK用1.6,包括编译级别和server jdk都是1.6,这个问题主要是因为使用了BoneCP,还有jbpm4.4,它的processEngine用到了javax.script.*包,JDK6才提供
     3.6.2.JDK1.5还是可以用的,不过要不是考虑多个项目的兼容性那就完全没必要,还是直接用JDK6吧!
     3.6.3.用JDK5(有点麻烦),首先还数据源,在BoneCP的前面有一个DBCP数据源,注释BoneCP,打开DBCP即可;关于jbpm4.4,javax.script.*包所有的类在网上有,已经有人打包了,下下来用上(不建议这样使用)
 
  3.7.两个测试账号:管理员(用户名和密码一样)admins;普通用户test001,密码是6个8
 
  3.8.关于环境部一致导致的错误说明:
     3.8.1.项目本身运行的环境是jdk1.6,tomcat6,tomcat jdk也是1.6,项目编译级别也是1.6,数据库是mysql5,数据库导入导出工具是Navicat Lite
     3.8.1.关于tomcat版本不一致的问题,
        A.如果是用的tomcat6,按上面说明部署是没问题的;
        B.如果用的是tomcat5.5,需要把3个juel开头的jar包直接放到项目中,不需要放到tomcat5\common\lib中,评论中有人出现了这个问题;
        C.如果用的是tomcat7就按tomcat6的配置来进行,需要说明的是tomcat7对dwr支持好像有问题,会抛异常,但是不影响程序运行     

  3.9.eclipse导入包图

业余框架整合-SSHD-(1)-整体概述(2011-06-02更新) - 每天积累一点 - 学无止境

  4.附件说明:*随时根据情况进行更新*

二、功能介绍

  声明:控制台界面是我从网上找了,然后进行修改的,当时记得下载说明里也不涉及什么版权问题,如有还麻烦通知声

  1.控制台登陆页 
业余框架整合-SSHD-(1)-整体概述(2011-06-02更新) - 每天积累一点 - 学无止境
 
  2.控制台首页

业余框架整合-SSHD-(1)-整体概述(2011-06-02更新) - 每天积累一点 - 学无止境


 
  评论这张
 
阅读(1308)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018