登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

学无止境

一点积累,与大家分享

 
 
 

日志

 
 

Android SDK 2.2 开发环境安装  

2010-09-13 17:32:53|  分类: Android开发 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
本文描述 Android SDK 安装过程,包括:Android SDK 2.2, Eclipse 3.5.2(galileo), 和 Andoid Development Tools (ADT) plugin。

  一个前提是用户已经安装了 JDK5.0 或 JDK 6.0。并且在系统环境变量设置了 Path 包含 JDK 的 bin 目录。

  [安装 Android 2.2]

  1. 下载Android 2.2 “开始包”

  windows 版:android-sdk_r06-windows.zip Mac 版:android-sdk_r06-mac_86.zip Linux 版android-sdk_r06-linux_86.tgz

  需要知道的是这个 zip 包并不是一个完整的软件包。Android 软件包采用“组件”的形式,用户可以根据需要选取组件。上述zip文件只包含了一个组件管理工具和一个基本的工具组件。

  2. 运行 Android SDK and AVD Manager.

  解压缩上面的 zip 包,可以运行 SDK Setup.exe, 即启动了Andoid SDK and AVD Manager。这个工具不但对Android SDK 组件进行管理,同时也是 Android 虚拟设备管理器。(关于后者,参见后面示例)。

  然后,可以用这个工具下载完整的 Android SDK 开发包。需要注意的如果网络使用了代理服务器,则(有可能)需在这个工具里配置代理服务器域名和端口。

  (本节内容参考:http://developer.android.com/sdk/installing.html 或 http://androidappdocs.appspot.com/sdk/installing.html)

  [安装 Eclipse]

  地址:http://www.eclipse.org/downloads/ 下载Eclipse 3.5.2 ,同样,只需解压缩即可。

  [安装 ADT]

  ADT 版本:

  ADT 0.9.7 (May 2010)

  ADT 0.9.6 (March 2010)

  ADT 0.9.5 (December 2009)

  ADT 0.9.4 (October 2009)

  使用 Eclipse 的升级管理器来安装ADT:

  1. 启动 Eclipse, 然后进入 Help > Install New Software.

  2. 在 Available Software 对话框里,点击 Add....

3. 出现 Add Site 对话框,在 Name 域里面输入一个名字 (例如, "Android Plugin") ,在 "Location" 域里面输入 URL: https://dl-ssl.google.com/android/eclipse/

  4. 注意:如果有问题,可以把 https 换成 http 试一下。点击 OK.

  5. 回到 Available Software 界面,你应该看到 "Developer Tools" 。选取 checkbox 。点击 Next, 接受 license agreement, 然后点击 Finish。

  6. 重起 Eclipse.

  [配置 ADT]

  配置 Eclipse 里的 ADT,使其指向 Android SDK 。

  1. 选取 Eclipse Window > Preferences...

  2. 选择 Android

  3. 点击 Browse... 定位 Android SDK 目录。

  4. 点击 Apply, 然后 OK.

  (本节内容参考:http://androidappdocs.appspot.com/sdk/eclipse-adt.html)

  [创建虚拟设备]

  开发环境建立好了,就可以写一个“Hello World”应用。但在之前,还需创建一个虚拟设备。

  运行 Eclipse, 选取 Window > Android SDK and AVD Manager.

  在左侧面板选择 Virtual Devices

  点击 New.

  出现 Create New AVD 对话框

  输入 AVD 名字, 例如 "my_avd".

  选取一个目标。目标是一个平台 (即,Android SDK 的版本,如 2.2)

  暂时忽略其他设置

  点击 Create AVD.

  [Hello World]

  1). 创建一个新的 Android project

  在创建 AVD 之后, 下个步骤就是在 Eclipse 里开始一个新的 Android 项目。

  运行 Eclipse, 选取 File > New > Project.

  如果 ADT 插件正确安装了,应该在 "Android Project" 里面有一项:"Android" 。(在你创建了一个或多个Android 项目后,一个 "Android XML File" 入口也应该可见。)

  选择 "Android Project" 并点击 Next.

  填写项目信息如下:

  Project name: HelloAndroid

  Application name: Hello, Android

  Package name: com.example.helloandroid (or your own private namespace)

  Create Activity: HelloAndroid

  点击 Finish.

  2). 编写代码:打印 Hello Android

  package com.android.helloandroid;

import android.app.Activity;

  import android.os.Bundle;

  import android.widget.TextView;

  public class HelloAndroid extends Activity {

  @Override

  public void onCreate(Bundle savedInstanceState) {

  super.onCreate(savedInstanceState);

  TextView tv = new TextView(this);

  tv.setText("Hello, Android");

  setContentView(tv);

  }

  }

  3)运行

  ADT 使运行非常简单:

  选取 Run > Run.

  选取 "Android Application".

  (Hello World, 参见:http://androidappdocs.appspot.com/resources/tutorials/hello-world.html )

  附:Android SDK release number:

  Android SDK 2.2 Revision 1 (May 2010) API Level: 8 Requires SDK Tools r6 or higher. FroYo

  Android SDK 2.1 Revision 2 (May 2010) API Level: 7 Requires SDK Tools r6 or higher. Eclair

  Android SDK 2.1 Revision 1 (Jan 2010) API Level: 7 Requires SDK Tools r6 or higher. Eclair

  Android SDK 2.0.1 API Level: 6 Requires SDK Tools r6 or higher. Eclair

  Android SDK 2.0 API Level: 5 Requires SDK Tools r6 or higher. Eclair

  Android SDK 1.6 Revision 3 (May 2010) API Level: 4 Requires SDK Tools r6 or higher. Donut

  Android SDK 1.6 Revision 2 (Dec 2009) API Level: 4 Requires SDK Tools r6 or higher. Donut

  Android SDK 1.6 Revision 1 (Sep 2009) API Level: 4 Requires SDK Tools r6 or higher. Donut

  Android SDK 1.5 Revision 3 (Jul 2009) API Level: 3 Requires SDK Tools r6 or higher. Cupcake

  Android SDK 1.5 Revision 2 (May 2009) API Level: 3 Requires SDK Tools r6 or higher. Cupcake

  Android SDK 1.5 Revision 1 (Api 2009) API Level: 3 Requires SDK Tools r6 or higher. Cupcake

  Android SDK 1.1 API Level: 2

  Android SDK 1.0 API Level: 1

  评论这张
 
阅读(668)| 评论(0)

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018